Commit 0a37d680 authored by Romulo Pereira Goncalves's avatar Romulo Pereira Goncalves
Browse files

Remove dependency on pinned version for rgdal, sp an sf

parent d65494f8
......@@ -20,7 +20,7 @@
"source": [
"### **0.0** - Pin the version of certain dependencies\n",
"\n",
"The `velox` library is not anymore developed. Its latest version does not compile with the latest version of `Boost`. To avoid warnings and issues with the migration of `rgdal` to `gdal 3 and proj 6` we decided to pin the versions of `sf`, `sp` and `rgdal`."
"The `velox` library is not anymore developed. Its latest version does not compile with the latest version of `Boost`."
]
},
{
......@@ -40,10 +40,7 @@
"source": [
"if (install_dependencies == TRUE) {\n",
" install.packages(\"remotes\")\n",
" install.packages(\"https://cran.r-project.org/src/contrib/Archive/BH/BH_1.69.0-1.tar.gz\", repos=NULL, type=\"source\")\n",
" install.packages(\"https://cran.r-project.org/src/contrib/Archive/sf/sf_0.9-0.tar.gz\", repos=NULL, type=\"source\")\n",
" install.packages(\"https://cran.r-project.org/src/contrib/Archive/sp/sp_1.4-4.tar.gz\", repos=NULL, type=\"source\")\n",
" install.packages(\"https://cran.r-project.org/src/contrib/Archive/rgdal/rgdal_1.5-12.tar.gz\", repos=NULL, type=\"source\") \n",
" install.packages(\"https://cran.r-project.org/src/contrib/Archive/BH/BH_1.69.0-1.tar.gz\", repos=NULL, type=\"source\") \n",
"}"
]
},
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment