Commit 6939beb6 authored by Hannes Diedrich's avatar Hannes Diedrich
Browse files

Updated Readme.

parent 59da11cf
......@@ -39,24 +39,26 @@ Clone the repository with:
## Installation
#### ... is easy (as long your python is compatible):
* Make sure your system meets all the Requirements (see above)
* Install the package by first going into the repository folder and then run:
* Install the package by running:
`python gts2_client/setup.py install`
#### Install a compatible python:
The following instruction is only valid for Linux distributions but can be adapted on Windows machines.
* Download and install at least Miniconda with default settings:
##### EITHER: Use install script and follow instructions:
`./install_py_gts2_client.sh`
##### OR: Per hand (expert modus):
* Download and install at least Miniconda with default settings:
```
wget https://repo.continuum.io/miniconda/Miniconda3-latest-Linux-x86_64.sh
chmod 755 Miniconda3-latest-Linux-x86_64.sh
./Miniconda3-latest-Linux-x86_64.sh -b
rm -f Miniconda3-latest-Linux-x86_64.sh
```
* Clone the gts2_repo with `git clone`
* Start a new shell and install needed packages for gts2_client using **gts2_client_conda_install.yml**:
* Install necessary packages for gts2_client using **gts2_client_conda_install.yml**:
`conda env update -f gts2_client_conda_install.yml`
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment