Commit ea0e8f29 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Added submodules to setup.py

updated __version__ and __versionalias__
Former-commit-id: 7b28a0b6
Former-commit-id: 09717a8f
parent 42909fdd
......@@ -2,8 +2,8 @@
__author__ = """Daniel Scheffler"""
__email__ = 'daniel.scheffler@gfz-potsdam.de'
__version__ = '0.3.3'
__versionalias__ = '20170609.03'
__version__ = '0.3.4'
__versionalias__ = '20170612.01'
from . import algorithms
......
#!/usr/bin/env python
# -*- coding: utf-8 -*-
from setuptools import setup
from setuptools import setup, find_packages
with open('README.rst') as readme_file:
readme = readme_file.read()
......@@ -17,18 +17,16 @@ requirements = [
test_requirements = [
# TODO: put package test requirements here
]
# TODO add data files
setup(
name='geomultisens',
version='0.3.3',
version='0.3.4',
description="GeoMultiSens - Scalable Multi-Sensor Analysis of Remote Sensing Data",
long_description=readme + '\n\n' + history,
author="Daniel Scheffler",
author_email='daniel.scheffler@gfz-potsdam.de',
url='https://github.com/danschef/geomultisens',
packages=[
'geomultisens',
],
packages=find_packages(), # searches for packages with an __init__.py and returns them as properly formatted list
package_dir={'geomultisens':
'geomultisens'},
include_package_data=True,
......@@ -48,6 +46,7 @@ setup(
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
],
test_suite='tests',
tests_require=test_requirements
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment