Commit 8760bbd7 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Updated some links in the docs and the setup requirements.

updated __version__ and __versionalias__


Former-commit-id: 9b245673
parent 605b67de
Pipeline #1962 failed with stage
in 13 seconds
...@@ -15,7 +15,7 @@ Types of Contributions ...@@ -15,7 +15,7 @@ Types of Contributions
Report Bugs Report Bugs
~~~~~~~~~~~ ~~~~~~~~~~~
Report bugs at https://github.com/danschef/geomultisens/issues. Report bugs at https://gitext.gfz-potsdam.de/danschef/GeoMultiSens/issues.
If you are reporting a bug, please include: If you are reporting a bug, please include:
...@@ -45,7 +45,7 @@ articles, and such. ...@@ -45,7 +45,7 @@ articles, and such.
Submit Feedback Submit Feedback
~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~
The best way to send feedback is to file an issue at https://github.com/danschef/geomultisens/issues. The best way to send feedback is to file an issue at https://gitext.gfz-potsdam.de/danschef/GeoMultiSens/issues.
If you are proposing a feature: If you are proposing a feature:
...@@ -62,7 +62,7 @@ Ready to contribute? Here's how to set up `geomultisens` for local development. ...@@ -62,7 +62,7 @@ Ready to contribute? Here's how to set up `geomultisens` for local development.
1. Fork the `geomultisens` repo on GitHub. 1. Fork the `geomultisens` repo on GitHub.
2. Clone your fork locally:: 2. Clone your fork locally::
$ git clone git@github.com:your_name_here/geomultisens.git $ git clone https://gitext.gfz-potsdam.de/danschef/GeoMultiSens
3. Install your local copy into a virtualenv. Assuming you have virtualenvwrapper installed, this is how you set up your fork for local development:: 3. Install your local copy into a virtualenv. Assuming you have virtualenvwrapper installed, this is how you set up your fork for local development::
......
...@@ -14,7 +14,7 @@ To install GeoMultiSens, run this command in your terminal: ...@@ -14,7 +14,7 @@ To install GeoMultiSens, run this command in your terminal:
$ pip install geomultisens $ pip install geomultisens
This is the preferred method to install GeoMultiSens, as it will always install the most recent stable release. This is the preferred method to install GeoMultiSens, as it will always install the most recent stable release.
If you don't have `pip`_ installed, this `Python installation guide`_ can guide If you don't have `pip`_ installed, this `Python installation guide`_ can guide
you through the process. you through the process.
...@@ -38,7 +38,7 @@ Or download the `tarball`_: ...@@ -38,7 +38,7 @@ Or download the `tarball`_:
.. code-block:: console .. code-block:: console
$ curl -OL https://github.com/danschef/geomultisens/tarball/master $ curl -OL https://gitext.gfz-potsdam.de/danschef/geoarray/repository/archive.tar.gz?ref=master
Once you have a copy of the source, you can install it with: Once you have a copy of the source, you can install it with:
...@@ -47,5 +47,5 @@ Once you have a copy of the source, you can install it with: ...@@ -47,5 +47,5 @@ Once you have a copy of the source, you can install it with:
$ python setup.py install $ python setup.py install
.. _Github repo: https://github.com/danschef/geomultisens .. _Github repo: https://gitext.gfz-potsdam.de/danschef/GeoMultiSens
.. _tarball: https://github.com/danschef/geomultisens/tarball/master .. _tarball: https://gitext.gfz-potsdam.de/danschef/geoarray/repository/archive.tar.gz?ref=master
...@@ -2,8 +2,8 @@ ...@@ -2,8 +2,8 @@
__author__ = """Daniel Scheffler""" __author__ = """Daniel Scheffler"""
__email__ = 'daniel.scheffler@gfz-potsdam.de' __email__ = 'daniel.scheffler@gfz-potsdam.de'
__version__ = '0.4.3' __version__ = '0.4.4'
__versionalias__ = '20170630.02' __versionalias__ = '20170703.01'
from . import algorithms from . import algorithms
......
git+https://gitext.gfz-potsdam.de/danschef/py_tools_ds.git py_tools_ds
git+https://gitext.gfz-potsdam.de/danschef/geoarray.git geoarray
git+https://gitext.gfz-potsdam.de/danschef/arosics.git arosics
git+https://gitext.gfz-potsdam.de/hollstei/sicor.git git+https://gitext.gfz-potsdam.de/hollstei/sicor.git
matplotlib matplotlib
numpy numpy
......
...@@ -12,9 +12,7 @@ with open('HISTORY.rst') as history_file: ...@@ -12,9 +12,7 @@ with open('HISTORY.rst') as history_file:
requirements = [ requirements = [
'matplotlib', 'numpy', 'scikit-learn', 'scipy', 'gdal', 'pyproj', 'shapely', 'ephem', 'pyorbital', 'dill', 'matplotlib', 'numpy', 'scikit-learn', 'scipy', 'gdal', 'pyproj', 'shapely', 'ephem', 'pyorbital', 'dill',
'pandas', 'numba', 'spectral', 'pyhdf', 'geopandas', 'iso8601', 'pyinstrument', 'geoalchemy2', 'sqlalchemy', 'pandas', 'numba', 'spectral', 'pyhdf', 'geopandas', 'iso8601', 'pyinstrument', 'geoalchemy2', 'sqlalchemy',
#'py_tools_ds', # pip install git+https://gitext.gfz-potsdam.de/danschef/py_tools_ds.git 'py_tools_ds', 'geoarray', 'arosics'
#'geoarray', # pip install git+https://gitext.gfz-potsdam.de/danschef/geoarray.git
#'arosics', # pip install git+https://gitext.gfz-potsdam.de/danschef/arosics.git
#'sicor', # pip install git+https://gitext.gfz-potsdam.de/hollstei/sicor.git #'sicor', # pip install git+https://gitext.gfz-potsdam.de/hollstei/sicor.git
] ]
setup_requirements = [] # TODO(danschef): put setup requirements (distutils extensions, etc.) here setup_requirements = [] # TODO(danschef): put setup requirements (distutils extensions, etc.) here
...@@ -22,15 +20,14 @@ test_requirements = requirements+ ['coverage'] ...@@ -22,15 +20,14 @@ test_requirements = requirements+ ['coverage']
setup( setup(
name='geomultisens', name='geomultisens',
version='0.4.3', version='0.4.4',
description="GeoMultiSens - Scalable Multi-Sensor Analysis of Remote Sensing Data", description="GeoMultiSens - Scalable Multi-Sensor Analysis of Remote Sensing Data",
long_description=readme + '\n\n' + history, long_description=readme + '\n\n' + history,
author="Daniel Scheffler", author="Daniel Scheffler",
author_email='daniel.scheffler@gfz-potsdam.de', author_email='daniel.scheffler@gfz-potsdam.de',
url='https://gitext.gfz-potsdam.de/danschef/GeoMultiSens', url='https://gitext.gfz-potsdam.de/danschef/GeoMultiSens',
packages=find_packages(), # searches for packages with an __init__.py and returns them as properly formatted list packages=find_packages(), # searches for packages with an __init__.py and returns them as properly formatted list
package_dir={'geomultisens': package_dir={'geomultisens':'geomultisens'},
'geomultisens'},
package_data={"database": ["geomultisens/database/*"]}, package_data={"database": ["geomultisens/database/*"]},
include_package_data=True, include_package_data=True,
install_requires=requirements, install_requires=requirements,
...@@ -43,8 +40,13 @@ setup( ...@@ -43,8 +40,13 @@ setup(
'Intended Audience :: Developers', 'Intended Audience :: Developers',
'License :: OSI Approved :: GNU General Public License v3 (GPLv3)', 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
'Natural Language :: English', 'Natural Language :: English',
"Programming Language :: Python :: 2",
'Programming Language :: Python :: 2.7', 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3.4+', 'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
], ],
test_suite='tests', test_suite='tests',
tests_require=test_requirements tests_require=test_requirements
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment