Commit 6ecc002b authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Use SPDX license identifier and set all files to GLP3+ to be consistent with...


Use SPDX license identifier and set all files to GLP3+ to be consistent with license headers in the source files. Excluded tests from being installed via 'pip install'. Set development status to 'stable'. Updated version info.
Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent 50de4305
Pipeline #14448 failed with stage
in 10 minutes and 1 second
......@@ -2,6 +2,14 @@
History
=======
0.18.6 (2020-10-12)
-------------------
* Use SPDX license identifier and set all files to GLP3+ to be consistent with license headers in the source files.
* Excluded tests from being installed via 'pip install'.
* Set development status to 'stable'.
0.18.5 (2020-09-25)
-------------------
......
......@@ -4,7 +4,7 @@ include HISTORY.rst
include LICENSE
include README.rst
recursive-include tests *
recursive-exclude tests *
recursive-exclude * __pycache__
recursive-exclude * *.py[co]
......
......@@ -7,7 +7,7 @@ pre-precessing pipeline for spatial and spectral fusion (i.e., homogenization)
of multispectral satellite image data. Currently it offers compatibility to
Landsat-5, Landsat-7, Landsat-8, Sentinel-2A and Sentinel-2B.
* Free software: GNU General Public License v3 (`license details <https://gitext.gfz-potsdam.de/geomultisens/gms_preprocessing/blob/master/LICENSE>`_)
* Free software: GNU General Public License v3 or later (GPLv3+) (`license details <https://gitext.gfz-potsdam.de/geomultisens/gms_preprocessing/blob/master/LICENSE>`_)
* Documentation: https://geomultisens.gitext-pages.gfz-potsdam.de/gms_preprocessing/doc/
* Code history: Release notes for the current and earlier versions of gms_preprocessing can be found `here <./HISTORY.rst>`_.
* OS compatibility: Linux
......
......@@ -24,5 +24,5 @@
# You should have received a copy of the GNU Lesser General Public License along
# with this program. If not, see <http://www.gnu.org/licenses/>.
__version__ = '0.18.5'
__versionalias__ = '20200925.01'
__version__ = '0.18.6'
__versionalias__ = '20201012.01'
......@@ -89,19 +89,19 @@ setup(
author="Daniel Scheffler",
author_email='daniel.scheffler@gfz-potsdam.de',
url='https://gitext.gfz-potsdam.de/geomultisens/gms_preprocessing',
packages=find_packages(), # searches for packages with an __init__.py and returns them as properly formatted list
packages=find_packages(exclude=['tests*']), # searches for packages with an __init__.py and returns a list
package_dir={'gms_preprocessing': 'gms_preprocessing'},
package_data={"database": ["gms_preprocessing/database/*"]},
include_package_data=True,
install_requires=requirements,
scripts=["bin/run_gms.py", "bin/run_gms.sh"],
license="GNU General Public License v3",
license="GPL-3.0-or-later",
zip_safe=False,
keywords='gms_preprocessing',
classifiers=[
'Development Status :: 4 - Beta',
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
'Natural Language :: English',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.6',
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment