Commit 5a05dbc5 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Added version.py which is from now on the only file containing the package version.

parent 44c93f36
...@@ -12,11 +12,10 @@ from . import options # noqa: F401 (imported but unused) ...@@ -12,11 +12,10 @@ from . import options # noqa: F401 (imported but unused)
from .options import config # noqa: F401 (imported but unused) from .options import config # noqa: F401 (imported but unused)
from .options.config import set_config # noqa: F401 (imported but unused) from .options.config import set_config # noqa: F401 (imported but unused)
from .processing.process_controller import process_controller # noqa: E402 from .processing.process_controller import process_controller # noqa: E402
from .version import __version__, __versionalias__ # noqa: E402
__author__ = """Daniel Scheffler""" __author__ = """Daniel Scheffler"""
__email__ = 'daniel.scheffler@gfz-potsdam.de' __email__ = 'daniel.scheffler@gfz-potsdam.de'
__version__ = '0.13.11'
__versionalias__ = '20180227.01'
__all__ = ['algorithms', __all__ = ['algorithms',
'io', 'io',
'misc', 'misc',
......
__version__ = '0.13.11'
__versionalias__ = '20180227.01'
...@@ -11,6 +11,10 @@ with open('README.rst') as readme_file: ...@@ -11,6 +11,10 @@ with open('README.rst') as readme_file:
with open('HISTORY.rst') as history_file: with open('HISTORY.rst') as history_file:
history = history_file.read() history = history_file.read()
version = {}
with open("...gms_preprocessing/version.py") as version_file:
exec(version_file.read(), version)
requirements = [ requirements = [
'matplotlib', 'numpy', 'scikit-learn', 'scipy', 'gdal', 'pyproj', 'shapely', 'ephem', 'pyorbital', 'dill', 'pytz', 'matplotlib', 'numpy', 'scikit-learn', 'scipy', 'gdal', 'pyproj', 'shapely', 'ephem', 'pyorbital', 'dill', 'pytz',
'pandas', 'numba', 'spectral>=0.16', 'geopandas', 'iso8601', 'pyinstrument', 'geoalchemy2', 'sqlalchemy', 'pandas', 'numba', 'spectral>=0.16', 'geopandas', 'iso8601', 'pyinstrument', 'geoalchemy2', 'sqlalchemy',
...@@ -26,7 +30,7 @@ test_requirements = requirements + ['coverage', 'nose', 'nose2', 'nose-htmloutpu ...@@ -26,7 +30,7 @@ test_requirements = requirements + ['coverage', 'nose', 'nose2', 'nose-htmloutpu
setup( setup(
name='gms_preprocessing', name='gms_preprocessing',
version='0.13.11', version=version['__version__'],
description="GeoMultiSens - Scalable Multi-Sensor Analysis of Remote Sensing Data", description="GeoMultiSens - Scalable Multi-Sensor Analysis of Remote Sensing Data",
long_description=readme + '\n\n' + history, long_description=readme + '\n\n' + history,
author="Daniel Scheffler", author="Daniel Scheffler",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment