setup.py 2.08 KB
Newer Older
1
2
3
#!/usr/bin/env python
# -*- coding: utf-8 -*-

4
from setuptools import setup, find_packages
5
6
7
8
9
10
11
12

with open('README.rst') as readme_file:
    readme = readme_file.read()

with open('HISTORY.rst') as history_file:
    history = history_file.read()

requirements = [
13
    'matplotlib', 'numpy', 'scikit-learn', 'scipy', 'gdal', 'pyproj', 'shapely', 'ephem', 'pyorbital', 'dill',
Daniel Scheffler's avatar
Daniel Scheffler committed
14
    'pandas', 'numba', 'spectral', 'pyhdf', 'geopandas', 'iso8601', 'pyinstrument', 'geoalchemy2', 'sqlalchemy',
15
    'py_tools_ds', 'geoarray', 'arosics'
16
    #'sicor', # pip install git+https://gitext.gfz-potsdam.de/hollstei/sicor.git
17
]
Daniel Scheffler's avatar
Daniel Scheffler committed
18
19
setup_requirements = [] # TODO(danschef): put setup requirements (distutils extensions, etc.) here
test_requirements = requirements+ ['coverage']
20
21
22

setup(
    name='geomultisens',
23
    version='0.4.4',
24
25
26
27
    description="GeoMultiSens - Scalable Multi-Sensor Analysis of Remote Sensing Data",
    long_description=readme + '\n\n' + history,
    author="Daniel Scheffler",
    author_email='daniel.scheffler@gfz-potsdam.de',
Daniel Scheffler's avatar
Daniel Scheffler committed
28
    url='https://gitext.gfz-potsdam.de/danschef/GeoMultiSens',
29
    packages=find_packages(), # searches for packages with an __init__.py and returns them as properly formatted list
30
    package_dir={'geomultisens':'geomultisens'},
Daniel Scheffler's avatar
Daniel Scheffler committed
31
    package_data={"database": ["geomultisens/database/*"]},
32
33
    include_package_data=True,
    install_requires=requirements,
Daniel Scheffler's avatar
Daniel Scheffler committed
34
    scripts=["bin/run_gms.py"],
35
36
37
38
    license="GNU General Public License v3",
    zip_safe=False,
    keywords='geomultisens',
    classifiers=[
Daniel Scheffler's avatar
Daniel Scheffler committed
39
        'Development Status :: 4 - Beta',
40
41
42
        'Intended Audience :: Developers',
        'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
        'Natural Language :: English',
43
        "Programming Language :: Python :: 2",
44
        'Programming Language :: Python :: 2.7',
45
46
47
48
49
        'Programming Language :: Python :: 3',
        'Programming Language :: Python :: 3.3',
        'Programming Language :: Python :: 3.4',
        'Programming Language :: Python :: 3.5',
        'Programming Language :: Python :: 3.6',
50
51
52
53
    ],
    test_suite='tests',
    tests_require=test_requirements
)