Commit 384b032d authored by Daniel Scheffler's avatar Daniel Scheffler

Added minimal version of pyproj.

Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent d126b284
Pipeline #11885 failed with stage
in 5 minutes and 43 seconds
......@@ -24,6 +24,7 @@ test_py_tools_ds:
- source activate ci_env
- export GDAL_DATA=/root/miniconda3/envs/ci_env/share/gdal
- export PYTHONPATH=$PYTHONPATH:/root # /root <- directory needed later
- conda update pyproj # FIXME remove as soon as docker container is rebuilt
- make nosetests
- make docs
artifacts:
......@@ -66,7 +67,7 @@ test_py_tools_ds_install:
# - conda config --set channel_priority strict # otherwise gdal or libgdal may be installed from defaults channel
# resolve some requirements with conda
- conda install --yes -q -c conda-forge numpy gdal pyproj shapely geopandas
- conda install --yes -q -c conda-forge numpy gdal pyproj>2.0.0 shapely geopandas
# run installer
- python setup.py install
......
......@@ -62,7 +62,7 @@ Using conda_, the recommended approach is:
# create virtual environment for py_tools_ds, this is optional
conda create -y -q -c conda-forge --name py_tools_ds python=3
source activate py_tools_ds
conda install -c conda-forge numpy gdal pyproj shapely scikit-image pandas
conda install -c conda-forge numpy gdal pyproj>2.0.0 shapely scikit-image pandas
Then install py_tools_ds using the pip installer:
......
......@@ -36,7 +36,7 @@ version = {}
with open("py_tools_ds/version.py") as version_file:
exec(version_file.read(), version)
requirements = ['gdal>=2.1.0', 'numpy', 'shapely', 'six', 'pandas', 'scikit-image>=0.16.0', 'geopandas', 'pyproj',
requirements = ['gdal>=2.1.0', 'numpy', 'shapely', 'six', 'pandas', 'scikit-image>=0.16.0', 'geopandas', 'pyproj>2.0.0',
'spectral']
setup_requirements = [] # TODO(danschef): put setup requirements (distutils extensions, etc.) here
test_requirements = requirements + ["coverage", "nose", "nose2", "nose-htmloutput", "rednose"]
......
......@@ -10,7 +10,7 @@ dependencies:
- gdal>=2.1.0
- conda-forge::libgdal # force to use conda-forge for libgdal to avoid package version incompatiblies due to mixed channels (libkea.so.1.4.7: cannot open shared object file: No such file or directory)
# - kealib # fix for libkea.so.1.4.7: cannot open shared object file: No such file or directory (not needed as long as libgdal and gdal are conda-forge packages)
- pyproj
- pyproj>2.0.0
- scikit-image>=0.16.0
- geopandas
- pip:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment