Added conda and Python update to test_geoarray_install.

Signed-off-by: Daniel Scheffler <danschef@gfz-potsdam.de>
4 jobs for master in 6 minutes and 10 seconds (queued for 1 second)
Status Job ID Name Coverage
  Test
passed #14817
test_geoarray

00:01:14

70.0%
failed #14819
test_geoarray_install

00:04:33

passed #14818
test_styles

00:00:22

 
  Deploy
skipped #14820
pages
 
Name Stage Failure
failed
test_geoarray_install Test
Package libpng conflicts for:
matplotlib -> libpng[version='>=1.6.23,<1.7|>=1.6.32,<1.7.0a0|>=1.6.34,<1.7.0a0|>=1.6.35,<1.7.0a0|>=1.6.36,<1.7.0a0|>=1.6.37,<1.7.0a0']
Package mkl_random conflicts for:
numpy -> mkl_random[version='>=1.0.2,<2.0a0']
Package cycler conflicts for:
matplotlib -> cycler[version='>=0.10']
Note that strict channel priority may have removed packages required for satisfiability.

ERROR: Job failed: exit code 1