Commit 9586436b authored by Daniel Scheffler's avatar Daniel Scheffler

Bugfix

updated __version__ and __versionalias__
parent d9fba7bf
......@@ -2,8 +2,8 @@
__author__ = """Daniel Scheffler"""
__email__ = 'danschef@gfz-potsdam.de'
__version__ = '0.3.1'
__versionalias__ = 'v20170612.01'
__version__ = '0.3.2'
__versionalias__ = 'v20170614.01'
from .baseclasses import GeoArray
......
......@@ -1026,9 +1026,9 @@ class GeoArray(object):
zoomable = False
warnings.warn('mpld3 is not available. Zooming disabled.')
assert self.geotransform and tuple(self.geotransform) != (0,1,0,0,0,-1),\
'A valid geotransform is needed for a map visualization. Got %s.' %self.geotransform
assert self.projection, 'A projection is needed for a map visualization. Got %s.' %self.projection
assert self.geotransform and tuple(self.geotransform) != (0,1,0,0,0,-1),\
'A valid geotransform is needed for a map visualization. Got %s.' %list(self.geotransform)
assert self.projection, 'A projection is needed for a map visualization. Got %s.' %self.projection
# get image to plot
nodataVal = nodataVal if nodataVal is not None else self.nodata
......
......@@ -20,7 +20,7 @@ test_requirements = [
setup(
name='geoarray',
version='0.3.1',
version='0.3.2',
description="Fast Python interface for geodata - either on disk or in memory.",
long_description=readme + '\n\n' + history,
author="Daniel Scheffler",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment