Commit 34529ecb authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Dropped Python 2.7 support due to end-of-life status.


Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent 3824cd61
......@@ -2,11 +2,12 @@
History
=======
0.11.2 (2021-05-07)
0.12.0 (2021-05-08)
-------------------
* The initialization of NoDataMask and BadDataMask is now much faster in case a boolean array is passed.
* Increased timeout for footprint computation to 5 seconds.
* Dropped Python 2.7 support due to end-of-life status.
0.11.1 (2021-05-07)
......
......@@ -33,7 +33,6 @@ import numpy as np
from osgeo import gdal, gdal_array, gdalnumeric
from shapely.geometry import Polygon
from shapely.wkt import loads as shply_loads
from six import PY3
# dill -> imported when dumping GeoArray
from py_tools_ds.convenience.object_oriented import alias_property
......@@ -53,12 +52,6 @@ from py_tools_ds.numeric.array import get_array_tilebounds
from .subsetting import get_array_at_mapPos
from .metadata import GDAL_Metadata
if PY3:
# noinspection PyCompatibility
from builtins import TimeoutError, FileNotFoundError
else:
from py_tools_ds.compatibility.python.exceptions import TimeoutError, FileNotFoundError
__author__ = 'Daniel Scheffler'
......
......@@ -11,4 +11,3 @@ pyepsg # optional dependency of cartopy, needed by geoarray
py_tools_ds>=0.14.35
scikit-image
shapely
six
six
dill
# geojson # optional
# folium # optional
......@@ -45,8 +45,7 @@ req = [
'pyepsg', # optional dependency of cartopy, needed by geoarray
'py_tools_ds>=0.14.35',
'scikit-image',
'shapely',
'six',
'shapely'
]
req_interactive_plotting = [
......
......@@ -21,7 +21,6 @@ dependencies:
- geojson
- pandas
- pyepsg # optional dependency of cartopy, needed by geoarray
- six
# test/docs requirements
- coverage
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment