Commit 6a172d37 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Improved installation instructions. Added conda-forge badge.


Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent 82b1a743
Pipeline #14320 passed with stages
in 7 minutes and 58 seconds
......@@ -42,6 +42,8 @@ Status
:target: https://danschef.gitext-pages.gfz-potsdam.de/arosics/coverage/
.. image:: https://img.shields.io/pypi/v/arosics.svg
:target: https://pypi.python.org/pypi/arosics
.. image:: https://img.shields.io/conda/vn/conda-forge/arosics.svg
:target: https://anaconda.org/conda-forge/arosics
.. image:: https://img.shields.io/pypi/l/arosics.svg
:target: https://gitext.gfz-potsdam.de/danschef/arosics/blob/master/LICENSE
.. image:: https://img.shields.io/pypi/pyversions/arosics.svg
......
......@@ -2,6 +2,9 @@
Installation
============
Using Anaconda or Miniconda (recommended)
-----------------------------------------
Using conda_, AROSICS is installed as follows:
......@@ -24,17 +27,35 @@ This is the preferred method to install AROSICS, as it will always installs the
automatically resolves all the dependencies.
If you don't use conda_, you may use the pip installer of AROSICS. However, please note that AROSICS depends on some
open source packages that may cause problems when installed with pip. Therefore, we strongly recommend resolving the
`dependencies of AROSICS`_ before the automatic installer is run.
Using pip (not recommended)
---------------------------
There is also a `pip`_ installer for AROSICS. However, please note that AROSICS depends on some
open source packages that may cause problems when installed with pip. Therefore, we strongly recommend
to resolve the following dependencies before the pip installer is run:
* cartopy
* gdal
* geopandas
* matplotlib
* numpy
* pandas
* pyfftw
* pykrige
* pyproj >2.2.0
* scikit-image
* shapely
To run the pip installer of AROSICS use:
Then, the pip installer can be run by:
.. code-block:: bash
$ pip install arosics
If you don't have `pip`_ installed, this `Python installation guide`_ can guide
you through the process.
.. note::
......@@ -42,10 +63,6 @@ To run the pip installer of AROSICS use:
from 2.7 onwards. However, we will continously drop the support for Python 2.7 in future.
If you don't have `pip`_ installed, this `Python installation guide`_ can guide
you through the process.
.. _pip: https://pip.pypa.io
.. _Python installation guide: http://docs.python-guide.org/en/latest/starting/installation/
.. _conda: https://conda.io/docs
.. _`dependencies of AROSICS`: https://gitext.gfz-potsdam.de/danschef/arosics/-/blob/master/requirements.txt
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment