Commit 404fd90b authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

Pinned shapely to versions older or equal than 1.6.4. Updated version info.


Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent bfda0cb5
Pipeline #6615 passed with stages
in 4 minutes and 46 seconds
...@@ -56,7 +56,7 @@ test_arosics_install: ...@@ -56,7 +56,7 @@ test_arosics_install:
- conda create -y -q --name arosics_testinstall python=3 - conda create -y -q --name arosics_testinstall python=3
- source activate arosics_testinstall - source activate arosics_testinstall
# resolve some requirements with conda # resolve some requirements with conda
- conda install --yes -q -c conda-forge numpy gdal scikit-image matplotlib pyproj shapely geopandas pandas - conda install --yes -q -c conda-forge numpy gdal scikit-image matplotlib pyproj "shapely<=1.6.4" geopandas pandas
- conda install --yes -q -c conda-forge libgdal ncurses # Fix for libgdal installed from defaults channel causing libkea.so.1.4.7: cannot open shared object file: No such file or directory - conda install --yes -q -c conda-forge libgdal ncurses # Fix for libgdal installed from defaults channel causing libkea.so.1.4.7: cannot open shared object file: No such file or directory
# run installer # run installer
- python setup.py install - python setup.py install
......
...@@ -22,5 +22,5 @@ ...@@ -22,5 +22,5 @@
# with this program. If not, see <http://www.gnu.org/licenses/>. # with this program. If not, see <http://www.gnu.org/licenses/>.
__version__ = '0.9.5' __version__ = '0.9.6'
__versionalias__ = '2020-01-08_02' __versionalias__ = '2020-02-11_01'
...@@ -20,7 +20,7 @@ Using conda_, the recommended approach is: ...@@ -20,7 +20,7 @@ Using conda_, the recommended approach is:
.. code-block:: bash .. code-block:: bash
$ conda install -c conda-forge numpy gdal scikit-image matplotlib pyproj shapely geopandas pandas cmocean $ conda install -c conda-forge numpy gdal scikit-image matplotlib pyproj "shapely<=1.6.4" geopandas pandas cmocean
3. Install optional libraries for AROSICS (only needed for some specific functions): 3. Install optional libraries for AROSICS (only needed for some specific functions):
......
...@@ -3,7 +3,7 @@ py_tools_ds>=0.14.25 ...@@ -3,7 +3,7 @@ py_tools_ds>=0.14.25
cmocean cmocean
numpy numpy
gdal gdal
shapely shapely<=1.6.4
scikit-image scikit-image
matplotlib matplotlib
geopandas geopandas
......
...@@ -39,7 +39,7 @@ version = {} ...@@ -39,7 +39,7 @@ version = {}
with open("arosics/version.py") as version_file: with open("arosics/version.py") as version_file:
exec(version_file.read(), version) exec(version_file.read(), version)
requirements = ['numpy', 'gdal', 'shapely', 'scikit-image', 'matplotlib', 'geopandas', 'pandas', 'geoarray>=0.8.17', requirements = ['numpy', 'gdal', 'shapely<=1.6.4', 'scikit-image', 'matplotlib', 'geopandas', 'pandas', 'geoarray>=0.8.17',
'py_tools_ds>=0.14.25', 'plotly', 'cmocean', 'six', 'folium>=0.6.0', 'geojson' 'py_tools_ds>=0.14.25', 'plotly', 'cmocean', 'six', 'folium>=0.6.0', 'geojson'
# 'pykrige' # conda install --yes -c conda-forge pykrige # 'pykrige' # conda install --yes -c conda-forge pykrige
# 'pyfftw', # conda install --yes -c conda-forge pyfftw=0.10.4 ; \ # 'pyfftw', # conda install --yes -c conda-forge pyfftw=0.10.4 ; \
......
...@@ -15,7 +15,7 @@ dependencies: ...@@ -15,7 +15,7 @@ dependencies:
- geopandas - geopandas
- pandas - pandas
- ipython - ipython
- shapely - shapely<=1.6.4
- matplotlib - matplotlib
- basemap - basemap
- holoviews - holoviews
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment