Commit 1e4c71c6 authored by Daniel Scheffler's avatar Daniel Scheffler
Browse files

The 'pykrige', 'pyfftw' and 'basemap' requirements are no longer optional...


The 'pykrige', 'pyfftw' and 'basemap' requirements are no longer optional since they are easily installable from conda-forge now. Updated requirements and installation instructions. Updated version info.
Signed-off-by: Daniel Scheffler's avatarDaniel Scheffler <danschef@gfz-potsdam.de>
parent 37ca24a1
Pipeline #12943 passed with stages
in 3 minutes and 32 seconds
...@@ -60,7 +60,7 @@ test_arosics_install: ...@@ -60,7 +60,7 @@ test_arosics_install:
- source activate arosics_testinstall - source activate arosics_testinstall
# resolve some requirements with conda # resolve some requirements with conda
- conda install --yes -q -c conda-forge numpy gdal scikit-image matplotlib 'pyproj>2.2.0' shapely geopandas pandas - conda install --yes -q -c conda-forge numpy gdal scikit-image matplotlib 'pyproj>2.2.0' shapely geopandas pandas pykrige pyfftw basemap
# run installer # run installer
- python setup.py install - python setup.py install
......
...@@ -527,7 +527,7 @@ class COREG(object): ...@@ -527,7 +527,7 @@ class COREG(object):
if not hv: if not hv:
raise ImportError( raise ImportError(
"This method requires the library 'holoviews'. It can be installed for Anaconda with " "This method requires the library 'holoviews'. It can be installed for Anaconda with "
"the shell command 'conda install -c ioam holoviews bokeh'.") "the shell command 'conda install -c conda-forge holoviews bokeh'.")
hv.notebook_extension('matplotlib') hv.notebook_extension('matplotlib')
hv.Store.add_style_opts(hv.Image, ['vmin', 'vmax']) hv.Store.add_style_opts(hv.Image, ['vmin', 'vmax'])
......
...@@ -22,5 +22,5 @@ ...@@ -22,5 +22,5 @@
# with this program. If not, see <http://www.gnu.org/licenses/>. # with this program. If not, see <http://www.gnu.org/licenses/>.
__version__ = '0.9.23' __version__ = '0.9.24'
__versionalias__ = '2020-09-25_02' __versionalias__ = '2020-09-28_01'
...@@ -20,17 +20,10 @@ Using conda_, the recommended approach is: ...@@ -20,17 +20,10 @@ Using conda_, the recommended approach is:
.. code-block:: bash .. code-block:: bash
$ conda install -c conda-forge numpy gdal scikit-image matplotlib 'pyproj>2.2.0' shapely geopandas pandas cmocean $ conda install -c conda-forge numpy gdal scikit-image matplotlib 'pyproj>2.2.0' shapely geopandas pandas cmocean basemap pykrige pyfftw
3. Install optional libraries for AROSICS (only needed for some specific functions): 3. Then install AROSICS using the pip installer:
.. code-block:: bash
$ conda install -c conda-forge basemap pykrige pyfftw
4. Then install AROSICS using the pip installer:
.. code-block:: bash .. code-block:: bash
......
...@@ -12,3 +12,6 @@ plotly ...@@ -12,3 +12,6 @@ plotly
six six
folium>=0.6.0 folium>=0.6.0
geojson geojson
pykrige
pyfftw
basemap
...@@ -25,8 +25,6 @@ ...@@ -25,8 +25,6 @@
"""The setup script.""" """The setup script."""
from setuptools import setup, find_packages from setuptools import setup, find_packages
import warnings
from pkgutil import find_loader
with open('README.rst') as readme_file: with open('README.rst') as readme_file:
...@@ -39,12 +37,10 @@ version = {} ...@@ -39,12 +37,10 @@ version = {}
with open("arosics/version.py") as version_file: with open("arosics/version.py") as version_file:
exec(version_file.read(), version) exec(version_file.read(), version)
requirements = ['numpy', 'gdal', 'shapely', 'scikit-image', 'matplotlib', 'geopandas', 'pandas', requirements = [
'geoarray>=0.8.30', 'py_tools_ds>=0.14.28', 'plotly', 'cmocean', 'six', 'folium>=0.6.0', 'geojson' 'numpy', 'gdal', 'shapely', 'scikit-image', 'matplotlib', 'geopandas', 'pandas', 'plotly', 'cmocean', 'six',
# 'pykrige' # conda install --yes -c conda-forge pykrige 'folium>=0.6.0', 'geojson', 'pykrige', 'pyfftw', 'basemap', 'geoarray>=0.8.30', 'py_tools_ds>=0.14.28'
# 'pyfftw', # conda install --yes -c conda-forge pyfftw=0.10.4 ; \ ]
# 'basemap', # conda install --yes -c conda-forge basemap; \
]
setup_requirements = [ setup_requirements = [
'setuptools' 'setuptools'
...@@ -73,31 +69,15 @@ setup( ...@@ -73,31 +69,15 @@ setup(
'Topic :: Scientific/Engineering', 'Topic :: Scientific/Engineering',
'License :: OSI Approved :: GNU General Public License v3 (GPLv3)', 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
'Natural Language :: English', 'Natural Language :: English',
"Programming Language :: Python :: 2",
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3', 'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.4', 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5', 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6', 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7', 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
], ],
test_suite='tests', test_suite='tests',
tests_require=test_requirements, tests_require=test_requirements,
setup_requires=setup_requirements, setup_requires=setup_requirements,
) )
# check for pyfftw
if not find_loader('pyfftw'):
warnings.warn('You need to install pyfftw manually (see https://pypi.python.org/pypi/pyFFTW) for speeding up '
'the computation. It is not automatically installed.')
# check for basemap
if not find_loader('mpl_toolkits.basemap'):
warnings.warn('You need to install basemap manually if you want to plot maps (see www./matplotlib.org/basemap). '
'It is not automatically installed.')
# check for pykrige
if not find_loader('pykrige'):
warnings.warn('You need to install pykrige manually if you want to interpolate tie point grids produced by AROSICS '
'(see https://github.com/bsmurphy/PyKrige). It is not automatically installed.')
...@@ -6,7 +6,6 @@ channels: &id1 ...@@ -6,7 +6,6 @@ channels: &id1
dependencies: dependencies:
- python=3.*.* - python=3.*.*
- pip - pip
- pyqt
- numpy - numpy
- gdal - gdal
- scikit-image - scikit-image
...@@ -20,6 +19,7 @@ dependencies: ...@@ -20,6 +19,7 @@ dependencies:
- holoviews - holoviews
- bokeh - bokeh
- pykrige - pykrige
- pyfftw
- cmocean - cmocean
- pip: - pip:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment