Commit bc19c80c authored by Niklas Bohn's avatar Niklas Bohn
Browse files

Updated version info.

parent eed2423e
......@@ -8,6 +8,16 @@ History
New features:
*
Bugfixes:
*
0.14.5 (2020-09-23)
-------------------
New features:
* Additional tables for multispectral mode are now downloaded during pip install.
Bugfixes:
* Moved imports of scikit-image from module level to function level to avoid
'ImportError: dlopen: cannot load any more object with static TLS'.
......
......@@ -31,7 +31,7 @@ Using conda_, the recommended approach is:
conda config --add channels conda-forge
conda install --yes -q gdal numpy scikit-image matplotlib pyproj rasterio shapely geopandas pyresample pytables h5py llvmlite pyfftw scikit-learn numba
Install SICOR via pip (recommended):
Install SICOR via pip (recommended). This may take a while since some needed tables are downloaded:
.. code-block:: bash
......@@ -60,8 +60,9 @@ After installation, some needed LFS files have to be downloaded:
git lfs pull
If you like to run SICOR in multispectral mode for Sentinel-2, several additional tables have to be downloaded.
In this case, you also need to install the ECMWF API client:
If you installed SICOR from Git and like to run it in multispectral mode for Sentinel-2, several additional tables have
to be downloaded (using pip, these tables are downloaded automatically). In this case, you also need to install the
ECMWF API client:
.. code-block:: bash
......
......@@ -15,7 +15,7 @@ Using conda_, the recommended approach is:
conda config --add channels conda-forge
conda install --yes -q gdal numpy scikit-image matplotlib pyproj rasterio shapely geopandas pyresample pytables h5py llvmlite pyfftw scikit-learn numba
Install SICOR via pip (recommended):
Install SICOR via pip (recommended). This may take a while since some needed tables are downloaded:
.. code-block:: bash
......@@ -44,8 +44,9 @@ After installation, some needed LFS files have to be downloaded:
git lfs pull
If you like to run SICOR in multispectral mode for Sentinel-2, several additional tables have to be downloaded.
In this case, you also need to install the ECMWF API client:
If you installed SICOR from Git and like to run it in multispectral mode for Sentinel-2, several additional tables have
to be downloaded (using pip, these tables are downloaded automatically). In this case, you also need to install the
ECMWF API client:
.. code-block:: bash
......
......@@ -24,6 +24,6 @@
# If not, see <https://www.gnu.org/licenses/>.
__version__ = '0.14.4.10'
__version__ = '0.14.5'
__versionalias__ = '20200923.01'
__author__ = 'Niklas Bohn'
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment